
 



 



 



 

 

CVM eSubmitter Quick Guide 
The CVM eSubmitter Application enables the creation of electronic submissions of regulatory 
information to CVM. It contains a number of data capturing tools to permit the capture of information in 
a structured format and provides helpful dialog boxes to reduce redundant responses. These benefits 
enable CVM to improve its review process of this regulatory information. This quick guide will instruct 
you on the basics for using the application. 

The Quick Guide includes the following sections: 

• Access the Software 

• Introductory Screen 

• Set Preferences 

• Create a New Submission 

• Submission Screen Layouts 

• Enter Submission Information 

• Single Screens vs. Tabular Screens 

• Save Submission Entries or Changes 

• Closing a Submission 

• Open an Existing Submission 

• Check Completeness of Submission 

• Package Submission Files 

• Transmitting Submissions to CVM 

• User Support 

Access the Software 
To start the CVM eSubmitter application: Go to the Start menu and select the CVM eSubmitter 
application, or select the CVM eSubmitter short-cut from the desktop. 

Application Start-Up Checks 

At start-up, the application performs several system checks. The primary check is to determine if the 
application is out-of-date. The CVM eSubmitter application attempts to perform auto-updates each time 
it is opened to ensure the most current submission templates and application features are always 
available. CVM releases updates approximately once a month. 

In the event that your organization blocks these updates through the use of firewall restrictions, it is the 
responsibility of the organization to frequently check whether updates are available, and manually 
reinstall, if necessary. 

Clicking the link below will display the latest updates that have been deployed for CVM eSubmitter: 

CVM eSubmitter Release History  

https://www.fda.gov/ForIndustry/FDAeSubmitter/ucm571932.htm


 

 

CVM eSubmitter Appears Out-Of-Date Warning Message 

If the CVM eSubmitter application has not 
received an update within 75 days, it displays 
the CVM eSubmitter Appears Out-Of-Date 
warning message.  

The warning message will continue to display 
at start-up until an update has been received 
or the software reinstalled.  

Clicking the Remind Me Later option will delay 
future messages for 7 days, while allowing the 
application to function normally until the issue 
is rectified. 

 

 

Getting Started 

The first time CVM eSubmitter opens, it displays a Getting Started Dialog. The getting started feature 
provides valuable information that will help step you through the process of setting up your 
environment, all the way through preparing and packaging your first submission.  Within the getting 
started you will find an overview of each step along with links to documents and websites that provide 
all the details needed to get you up and running. 

Clicking the Skip at Start-Up option will prevent the dialog from displaying in future start-ups. However, 
the getting started feature can always be reopened at any time from the Help menu. 

Getting Started Dialog 

Getting started includes the following sub-
sections: 

• Application Overview 
• Obtaining FDA and CVM Accounts for 

Transmitting Submissions 
• Configuring the CVM eSubmitter 

Application 
• Reviewing the Steps for Preparing a 

Submission 
• Keeping Up with Application Updates 
• Beginning Your First Submission 

 

 

Introductory Screen 
The CVM eSubmitter application window contains three distinct areas: the menu bar, tool bar, and main 
display area. The Introductory Screen is the main starting point when the CVM eSubmitter application 
opens and initially fills the main display area. 



 

 

CVM eSubmitter Introductory Screen 

 

The introductory screen contains the following sub-areas: the Application Identification at the top, 
common Menu Options along the left, and the Informational Message Area to the right.  

The common features available from the Menu Options are as follows. 
• Create New Submission:  Allows you to create a new submission. The Create New Submission 

Dialog will appear. See the section on Creating a New Submission for more detailed information. 
• Open Existing Submission:  Allows you to open an existing submission. The Open Existing 

Submission Dialog will appear. See the section on Opening an Existing Submission for more 
detailed information. 

• CVM eSubmitter Quick Guide:  Launches this CVM eSubmitter Quick Guide. 
• Exit Application:  Closes the CVM eSubmitter application. 
• Application Version and Last Update Date:  Provides easy access to identify the application 

version and last updated date. It is located near the bottom of the menu options area. 

The features available from the Informational Message Area are as follows. 
• Several Distinct Informative Tabs:  Containing the following content: 

o Welcome Message: Overview of the electronic submission program. 
o Alerts and News:  List of concerns/issues and news with details. 
o Helpful Tips:  List of helpful tips with details. 
o Addresses and Contacts:  List of contacts and addresses with details. 
o Links:  List of useful links. 



 

 

o Frequently Asked Questions:  Additional support based on Frequently Asked Questions 
(FAQ) received to date from existing users of the application. 

o History:  List of all updates to the application software. 
• Navigation Options:  Clicking directly on the message tabs or using the Next and Previous 

arrows on each side of the Message header. 
• Expand/Collapse Option:  Clicking the arrow located at the leftmost position of the Message 

header to either expand the message area to fill the application window or collapse it to its 
normal size. 

• Category Filter:  Within each message tab is a filter to limit the message content to an individual 
program within CVM. Changes to the filter setting are universal across the message tabs. 

• New Content Status Indicator:  Included within each tab name is a status indicator (i.e., star) 
identifying when new content is available since the last time viewed. By clicking the Mark as 
Read? option you indicate that you have read a message and the star will disappear. The star 
will only reappear when new content is available for viewing. 

Set Preferences 
The CVM eSubmitter application provides configuration options through application preferences. 
Preferences are settings that you can alter to change the way the application behaves. By adjusting the 
values within preferences you configure the application to best suit your working needs. 

Application Preferences 

Preferences includes the following 
configuration categories: 

• File Locations of Working Folders 
• Networking 
• Auto-Save 
• Starting Layout 
• Adobe File Viewer Override 
• Application Messages 

To update application preferences, select 
Preferences from the File menu. 

For a detailed explanation of each preference, 
see the CVM eSubmitter Preferences Quick 
Guide located within the Manual subfolder of 
the application. 

 

 

Informational Tips! 
• Many screens contain light bulbs, click on a light bulb to view helpful hints. 
• Data entry fields that contain a blue circle denote a required response. 



 

 

Create a New Submission 
To create a new submission, click on the Create New Submission button from the Menu Options of the 
Introductory Screen, or select the New option from the File menu, or click the New button on the 
application tool bar to open the Create New Submission Dialog. 

Create New Submission 

Creating a new submission is a two-step 
process: 

Step 1. Select a Submission Type 

Within the first screen of the Create New 
Submission Dialog is a submission type list and 
description area. Selecting a type from the list 
displays information related to the 
corresponding submission type. Once you 
have selected an appropriate type, click the 
Next button. 

Step 2: Provide Submission Details 

Complete the fields within the second screen 
of the Create New Submission Dialog. 

Descriptive Name:  Enter any descriptive 
name, as long as it is unique to the submission 
list. Use a name that distinctly identifies the 
report to you. 

File Name:  Enter a valid file name for the 
submission data file. Use only alphanumeric 
characters. Do not use symbols. 

Additional Comments:  Enter any additional 
information about this report (optional). 

Click the Create button to generate the 
submission data file and open the submission 
within the submission data screen. 

 

 

 

Submission Screen Layouts 
When a submission is available for data entry the main display area switches from the introductory 
screen to the submission data screen. The submission data screen contains two distinct display areas. 
The Outline area that provides a table of contents listing the sections contained within the submission, 
and the Screen area that displays the data entry form for the selected section. The application supports 
two different layout approaches for the submission data screen: Simple and Extended. 

The simple layout separates the outline and screens areas across two distinct views where only one is 
visible at a time, while the extended layout combines the outline and screen areas into a single view 
with a resizable splitter between the two areas. Layout views can be switched from the View menu or 
by clicking between the Simple and Extended view options on the tool bar. 



 

 

While the extended layout provides constant visible tracking of where you are within the submission, 
the simple layout provides better support for smaller screens. By default the layout is set to Extended. 
 

Simple Layout (left) vs. Extended Layout (right) 
 

 
 

Navigating the Submission 

Navigating through the submission is as follows: 
• If you are in the Simple Layout, use the navigation buttons on the button bar at the bottom of 

the screen to advance to the next and previous screens. 
• If you are in the Extended Layout, use the outline area, and activate each section by double 

clicking on the section name to load the questions. You may also use the navigation arrows on 
the tool bar at the top to move to the next or previous section. 

Enter Submission Information 
Performing data entry within a submission only requires providing a response to questions as they are 
presented.   

The following approaches are used in the collection of data within the application: 
• Common Data Entry Control Types:  Various types of controls are provided based on the types 

of information to be collected. The goal being to simplify data entry while also trying to improve 
the quality of the data collected. Examples of simple control types included are: drop-down lists 
with preset values, check boxes, radio button groups, plain text, numeric, dates, and tables. 

• Data Validation:  Performing checks to ensure individual data is being captured in the correct 
format. Providing user feedback when values are not in the correct format and not allowing 
invalid data to be saved until corrected.  

• Rule Validation:  Rules are condition/action-based and can work across multiple questions. They 
evaluate logical criteria and perform actions based on the result (e.g., If “Other” is selected from 
a list than a response is required to explain why “Other” was chosen).  

• Completeness:  Provides a measurement that all required responses have been provided. A 
submission cannot be packaged unless it is complete. Completeness indicators are provided 



 

 

throughout the data entry. The Outline area represents sections as folders. Each folder has an 
indicator to identify if the section is complete.  A “check mark” represents complete and a 
“question mark” represents that required responses are missing. In addition, a Missing 
Data/Validation Issues Report is always available from the Output menu to list any missing data 
or issues within the submission. 

In addition to the simple data entry control types, there are also complex control types that support the 
data entry of both complex data, as well as a compound data (i.e., combination of multiple data items). 

Complex data entry controls include: 
• Contact and Address Information copied from the Address Book 
• File Attachments 
• Rich Text Content (formatted text, lists, tables) 

Address Book 

Contact, firm, and address information is considered to be compound data due to the inherent nature of 
the relationship between the data. It is also presents an opportunity for a high level of reuse. As a result, 
the application provides a built-in Address Book capability to gather commonly used contact, firm, and 
address information. 

Address Book 

Contact and Firm data collection will typically 
be preceded with buttons that interface with 
the Address Book (see buttons circles in red) 

The first button provides an option to Copy 
From the address book to fill in the related 
fields on the screen, while the second button 
provides an option to Copy To the address 
book the information from the fields on the 
screen. 

The most common approach to building the 
address book is to manually enter address 
information into the submission data entry 
when first used, and select Copy To address 
book to preserve it for future submissions. 
However, there is also an address book option 
on the Tools menu that allows direct entry 
into the address book. 

 

 

File Attachment 

Submission forms are designed to collect both discrete data (i.e., individual fields on a form), as well as 
file attachment references to be included within the submission package. In addition, some questions 
may support only one reference to a file attachment, while others might offer the option to attach 
multiple files. 



 

 

The types of files that can be attached are limited. CVM eSubmitter currently supports the following 
types of file: 

• Portable Document Form (pdf) 
• eXtensible Markup Language (xml) 
• SAS XPORT (xpt) 

The types of files supported can be further restricted on a question by question basis. 

File names should not contain more than 250 characters. Do not use symbols when naming the files for 
attachments. For example, do not use slashes (/) (\), tildes (~), asterisks (*), periods (.), brackets [ ], 
single quotation marks (‘), double quotation marks (“) or parentheses ( ). 

Attaching a File 

Attaching a file is a multi-step process: 

Initiate to Add a File Reference from a 
Question 

Click the Add File (i.e., Plus Sign) button from 
a File Attachment type question to open the 
file attachment dialog. 

Option 1. Check Existing File Attachment 
List 

Check the list of files that have already been 
attached for the submission.  A file can only 
be attached once, but it can be referenced 
across multiple questions.  If the file is already 
in the previously attached list, select the file, 
and click the Attach Selected File button. 

Option 2. Select a New File to Add to the 
File Attachment List 

Click the Select File button (i.e., folder image) 
to open the file browser dialog and navigate 
to the file to be added. 

Once selected, add a Descriptive Title for the 
file (a title is required and must be unique 
across all file included within a submission). 

Finally, click the Attach Selected File button. 

Once a file has been selected you will return 
to the question and the question will be 
updated to reflect the file chosen. 

 

 

 

 

 

 



 

 

Rich Text 

The application supports rich text responses formatted in the HyperText Markup Language (HTML). Not 
all questions allow HTML responses, but some do based on the nature of the expected response (e.g., 
tables, lists, special symbols, equations). The most common approach for including HTML responses in a 
submission is to copy and paste the formatted content from an existing document (e.g., Word). The 
Operating System (OS) will automatically perform the translation of the source rich text into HTML. 

Single Screens vs. Tabular Screens 
The application supports two types of data entry screens: 

• Singular 
• Tabular 

Singular Screen 

Singular screens only support one instance of 
the data collected. In the example at the 
right, this submission supports the entry of 
only one Product Description. 

Within the outline area, Singular screens are 
referenced by a single folder. 

 

 

Tabular Screen 

Tabular screens support multiple instances of 
the data collected. In the example provide at 
the right, this submission supports the entry 
of Type II Master Files. 

Within the outline area, Tabular screens are 
referenced by a double folder. 

Tabular screens support three views: 
• Detail:  Displays the individual 

questions for data entry 
• List:  Displays a list referencing all 

items included 
• Info: Displays guidance information 

describing the options available 
In general, tabular screens support adding, 
editing, and deleting; navigation between 
items; and reordering. 

 

 

 

Some tabular screens may be linked together through a parent/child relationship. If this parent/child 
relationship exists, you will see a header bar on the child screens indicating which list item within the 
parent table you are currently entering data for. 



 

 

Save Submission Entries or Changes 
While moving through a submission, any changes made to question responses are automatically 
updated within memory (e.g., the user made a change to a question response, went to another section 
of the submission, and returned to see that the changes to the response were still in effect). 

There are two approaches to saving your changes: 
1. Click the Save button on the tool bar or select the Save option from the File menu when you are 

at a point that you want to save your progress. 
2. Turn on Auto-Save and provide a time Interval within the Preferences and the application will 

automatically perform saves based on the interval provided. To learn more about auto-save 
review the CVM eSubmitter Preferences Quick Guide located with the Manual subfolder of the 
application. 

Saves will not be performed while there is a validation issue within the response of the current question. 
The validation issue will need to be corrected before a save can be completed. In addition, the 
application will remind you to save if data has been changed and you are about to perform an operation 
that would result in losing your changes (e.g., such as opening another submission or exiting the 
application). 

Closing a Submission 
To close a submission, select the Close option from the File menu. Once closed, the application will 
return to displaying the Introductory Screen. 

Open an Existing Submission 
To open an existing submission, click on the Open Existing Submission button from the Menu Options 
of the Introductory Screen, or select the Open option from the File menu, or click the Open button on 
the application tool bar to open the Open Existing Submission Dialog. 

Open Existing Submission 

The Open Existing Submission Dialog allows 
you to select an existing submission or create a 
new one. As you create new submissions they 
will be added to this list. 

The available options are: 
• Open: Opens the selected submission 

within the list by either clicking the 
button or double clicking on the select 
item 

• Cancel:  Closes the dialog with no 
changes 

• Create New Submission: Opens the 
Create New Submission Dialog 

 

 
 



 

 

Check Completeness of Submission 
To check for completeness, you must identify if any data is missing or validation issue remain within 
your submission content.  You will not be able to package your submission until it is complete. 

Select the Missing Data/Validation Issues Report from the Output menu to open the report within your 
default browser. The report will either state that there are no missing data or validation issues, or it will 
identify the questions and screens where the problems are located. After fixing any issues, you are ready 
to proceed to the packaging process. 

Package Submission Files 
After completing the submission data entry and verifying that there is no missing or invalid information, 
you are ready to package the files for submission.  For a detailed explanation of the packaging process, 
see the CVM eSubmitter Packaging Quick Guide located within the Manual subfolder of the application. 

Transmitting Submissions to CVM 
While the application allows you to create electronic submissions, it does not transmit the content to 
FDA. Submissions generated within CVM eSubmitter must be transmitted using FDA’s Electronic 
Gateway System (ESG) and validated using CVM’s Electronic Submission System (ESS). 

For a detailed explanation of registering with the FDA’s ESG and CVM’s ESS, see the Registering with FDA 
and CVM to Submit Electronically located within the Manual subfolder of the application. 

User Support 
For CVM eSubmitter Program Support Contact:  cvmesubmitter@fda.hhs.gov. 

For FDA Electronic Submission Gateway (ESG) Support Contact: ESGHelpDesk@fda.hhs.gov. 

For CVM Electronic Submission System (ESS) Support Contact: cvmdcu@fda.hhs.gov. 

mailto:cvmesubmitter@fda.hhs.gov?subject=CVM%20eSubmitter%20Support
mailto:ESGHelpDesk@fda.hhs.gov?subject=ESG%20Support
mailto:cvmdcu@fda.hhs.gov?subject=ESS%20Support


: A Federal agency may not conduct or sponsor, and a person is not required to respond to, a collection of information, 
unless it displays a current valid OMB control number. The public reporting burden for the collection of information is estimated to vary from 5 to 10 minutes, with an 
average of 8 minutes per response, including time for reviewing instructions, searching existing data sources, gathering and maintaining the necessary information, and 
completing and reviewing the collection of information.  Send comments regarding the burden estimate or any other aspect of this collection of information to the Food and 
Drug Administration, Center for Veterinary Medicine, 7500 Standish Place, Rockville, MD 20855. 

Select ‘Add’, 'Delete' or 'Change' then complete the required information. 

ADD <Coordinators Only> DELETE <Coordinators Only> CHANGE 

Stakeholder Name:

     Stakeholder Company Name:

 Company Address 1:

 Company Address 2: 

City: St/Prov: Postal Code: 

Country: 

Stakeholder Phone: 

Stakeholder Email Address: 

 I certify that the applied digital signature is mine. 

Stakeholder Name: 

Stakeholder Email Address: 

Guidance Import Data  Reset Form
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